Twilio outage impacting Turvo SMS notifications

Incident Report for Turvo

Resolved

This incident has been resolved.
Posted Sep 09, 2026 - 18:13 UTC

Monitoring

Twilio has identified and resolved the issue. The service is now operating normally and SMS notifications are flowing through.
Posted Sep 09, 2026 - 17:15 UTC

Update

The issue is still persisting. We are actively following up with the Twilio team for an update and resolution.
Posted Sep 09, 2026 - 16:02 UTC

Identified

Twilio is having an outage and impacting Turvo SMS notifications.

Refer for more details -> https://status.twilio.com/
Posted Sep 09, 2026 - 13:27 UTC
This incident affected: Driver app and Other Systems.