Delay in Turvo analytics data refresh

Incident Report for Turvo

Resolved

Data restoration has been successfully completed, and the analytics data is now available.
Posted Jun 04, 2026 - 00:08 UTC

Monitoring

The data synchronization issue has been resolved, and the required jobs have been successfully initiated.

The Tableau refresh process is currently in progress and is expected to take approximately 4–5 hours. The latest data in Turvo Analytics should be available in Tableau between 8:00 PM and 8:30 PM CST.
Posted Jun 03, 2026 - 21:02 UTC

Identified

We are currently experiencing delays in Turvo Analytics data refresh. Teams are actively working on fixing the issue.
Posted Jun 03, 2026 - 19:41 UTC
This incident affected: Analytics.