Turvo app UI slowness

Incident Report for Turvo

Resolved

The issue has been resolved, and all services are operating normally.
Posted Jul 28, 2026 - 15:19 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 28, 2026 - 15:09 UTC

Monitoring

The application has recovered, and performance has returned to normal. Our team will continue to closely monitor the platform.
Posted Jul 28, 2026 - 15:07 UTC

Identified

We are currently experiencing intermittent slowness. The affected services have been scaled, and our engineering team is actively monitoring and verifying the platform.
Posted Jul 28, 2026 - 14:36 UTC
This incident affected: Shipments, Search, and Other Systems.