Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2026 - 04:01 UTC
Scheduled
Turvo will be conducting scheduled maintenance on the Production environment overnight on May 10, 2026 during the listed time frames across timezones:
Eastern Daylight Time (EDT): 12:01 AM to 4:30 AM on May 10 Pacific Daylight Time (PDT): 9:01 PM on May 09 to 1:30 AM on May 10
Like other maintenance windows, the Turvo platform will be down during this windows. You can check the status of the Turvo platform during maintenance windows by visiting Turvo's Status page. Required actions: If you run overnight API jobs, these need to be paused before the maintenance window begins and can be resumed after the maintenance window ends. If you do not run overnight API jobs, no action is needed.
All services will be restored once the window is completed. Unless otherwise informed, you can resume your API jobs at that time.
Please contact your CSM or Turvo representative if you have questions regarding this maintenance window. Note: The 2026 Planned Maintenance Schedule in the Help Center lists all of our planned maintenance windows for 2026.
Posted May 07, 2026 - 15:37 UTC
This scheduled maintenance affected: Shipments, Search, Analytics, Integration, Orders, Items, Inventory, Driver app, Mobile app, Offers, Appointments, Other Systems, and API.