Turvo app slowness

Incident Report for Turvo

Resolved

The issue causing performance degradation has been resolved. All services are operating normally.
Posted Mar 17, 2026 - 13:26 UTC

Monitoring

Services have now been fully restored and are operating normally.
Posted Mar 17, 2026 - 13:17 UTC

Identified

Some users may have experienced slow performance due to backend system issues. Teams have identified the issue and applied the fix.
Posted Mar 17, 2026 - 13:05 UTC
This incident affected: Other Systems.