Delay in Turvo analytics data refresh

Incident Report for Turvo

Resolved

The issue is completely resolved now and we have the latest data in analytics
Posted Feb 03, 2026 - 09:31 UTC

Update

The cluster restoration has been completed, and data synchronization jobs have now been initiated. We will continue to monitor progress and share updates as needed.
Posted Feb 03, 2026 - 01:19 UTC

Update

Restoration of the Analytics cluster is currently in progress. We will provide an update as soon as data synchronization has resumed.
Posted Feb 02, 2026 - 20:56 UTC

Identified

We are currently experiencing delays in Turvo Analytics data refresh. Teams are actively working on fixing the issue.
Posted Feb 02, 2026 - 15:12 UTC
This incident affected: Analytics.