Temporary Disruption in Data Synchronization

Incident Report for Turvo

Resolved

The issue has been resolved, and the Triumph Business Capital (TBC) integration is now functioning as expected. Systems remain stable, and we will continue to monitor for ongoing reliability.
Posted 1 month ago. Jun 18, 2025 - 00:29 UTC

Monitoring

The affected data has been successfully synced, and we’ve reflowed the data to Triumph Business Capital. Our team will continue to monitor the systems closely to ensure stability.
Posted 1 month ago. Jun 17, 2025 - 19:41 UTC

Investigating

A recent data migration job led to a temporary sync disruption, which may have affected some data visibility. Issue is being investigated.

Triumph Business Capital integration is impacted, and has been paused temporarily.
Posted 1 month ago. Jun 17, 2025 - 16:53 UTC
This incident affected: Integration.