Email Notifications Issue

Incident Report for Turvo

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 16:18 UTC

Monitoring

Email notifications are now operating normally. The issue causing email delivery has been resolved. Our team will continue monitoring the system to ensure stability.
Posted Mar 11, 2026 - 15:52 UTC

Investigating

We are currently experiencing issue with email notifications. Our team is actively investigating the issue and working to restore normal delivery as soon as possible.
Posted Mar 11, 2026 - 15:35 UTC
This incident affected: Other Systems.