Service Degradation Impacting Reporting & Shipment List

Incident Report for Turvo

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 14:28 UTC

Monitoring

The issue impacting reporting and the shipment list has been resolved.
Services are now fully operational. Team continues to monitor the system.
Posted Apr 15, 2026 - 13:46 UTC

Identified

We are currently experiencing an issue with one of our services, which is impacting reporting and the shipment list.
The team has identified the root cause and is actively working on a fix.
Posted Apr 15, 2026 - 13:20 UTC
This incident affected: Other Systems.