Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 15, 2025 - 04:00 UTC
Scheduled
This message serves as a reminder regarding the scheduled maintenance on Sunday, June 15, 2025, from 12:01 AM to 4:30 AM Eastern Time.
If you have any overnight Public API jobs that send or receive data, please make sure to pause them before the maintenance begins and resume them once it concludes. Failure to do so may result in 5xx server errors, and you'll need to restart your jobs after the maintenance window to ensure proper data transfer.
If you do not run overnight API jobs, no action is required on your part. All services will be fully restored once the maintenance is complete, at which point you can resume your API jobs unless you receive further notification.
If you have any questions regarding this maintenance, please don't hesitate to reach out to your dedicated CSM or Turvo representative.
Posted Jun 13, 2025 - 07:03 UTC
This scheduled maintenance affected: Shipments, Search, Analytics, Integration, Orders, Items, Inventory, Driver app, Mobile app, Offers, Appointments, Other Systems, and API.