Delay in Turvo analytics data refresh

Incident Report for Turvo

Resolved

Data is now fully in sync and the issue has been resolved. Systems are operating normally.
Posted Oct 29, 2025 - 19:43 UTC

Identified

Our engineering team identified the root cause as a slowdown in the data sync job. The job has been restored and is now processing normally. We expect all data to be fully updated by 10/29, 3 PM EST.
Posted Oct 29, 2025 - 14:02 UTC

Investigating

We are currently experiencing delays in data refresh to Turvo analytics. We are actively looking into the issue.
Posted Oct 29, 2025 - 12:37 UTC
This incident affected: Analytics.