Delay in Webhooks from Turvo

Incident Report for Turvo

Resolved

We are sending the webhook events with no delay now
Posted Jul 01, 2025 - 17:08 UTC

Monitoring

We have identified the issue and fixed it. We are monitoring
Posted Jul 01, 2025 - 17:03 UTC

Investigating

There will be a delay in Turvo sending webhooks events for any updates/create entities done. We are working to fix this
Posted Jul 01, 2025 - 16:43 UTC
This incident affected: Other Systems.