Turvo app UI slowness

Incident Report for Turvo

Resolved

The issue has been resolved, and all services are operating normally.
Posted Jun 29, 2026 - 16:48 UTC

Monitoring

The application has recovered, and performance has returned to normal. We will continue to monitor the environment to ensure stability.
Posted Jun 29, 2026 - 16:28 UTC

Identified

We are currently experiencing intermittent slowness due to a traffic spike. The affected services have been scaled, and our engineering team is actively monitoring and verifying that performance is returning to normal.
Posted Jun 29, 2026 - 16:16 UTC
This incident affected: Shipments and Search.