Delay in webhook event processing

Incident Report for Turvo

Resolved

The issue has been resolved, and all backlogged webhook events have been successfully cleared. Systems are now operating as expected.
Posted Jul 03, 2025 - 14:23 UTC

Identified

We are currently experiencing delays in webhook event dispatch due to a slow response from one of our backend integrations. Our teams have identified the issue and are actively working on a fix.
Posted Jul 03, 2025 - 13:41 UTC
This incident affected: Other Systems.