Turvo to COMDATA/Comcheck - integration issue

Incident Report for Turvo

Resolved

The issue has been resolved, and COMDATA integration updates are now flowing as expected.
Posted Jun 16, 2025 - 18:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2025 - 18:13 UTC

Update

We have identified the root cause and a fix is scheduled for deployment tonight (US time). In the meantime, a mitigation is in place, and we are actively working to address and reprocess the failed transactions.
Posted Jun 13, 2025 - 17:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 13, 2025 - 12:23 UTC

Identified

We are currently experiencing issues due to recent changes on the COMDATA side, which are affecting integration(Comdata/Comcheck) with our systems. Both COMDATA and AppData teams are actively working together to resolve the issue.

Impacted integration: Turvo to COMDATA
Posted Jun 12, 2025 - 15:47 UTC
This incident affected: Integration.